Bildanhänge im Forum

Auf den Experts-Seiten gilt normalerweise die Regel: Was Anhänge haben kann, ist moderiert (muss von einem Administrator frei geschaltet werden), nur Beiträge im Forum sind nicht moderiert, können aber keine Anhänge haben. Wir hatten Angst, zu einer illegalen Plattform für Copyright-geschütztes Material zu werden, dass ist der ganze Grund.

In einem off-topic-Posting vor kurzen hab ich versprochen, mal zu beschreiben, wie man das austrickst, wenn man mal unbedingt ein Bild an einem Forum-Beitrag braucht. Wer dieses Forum missbrauchen will, wird wahrscheinlich nicht auf dieses Posting kommen, deshalb hab ich da wenig Bedenken.

Der eigentliche Trick: Ihr macht ein ganz normales Posting unter »Beitrag schreiben«, z.B. mit »Beitrag mit Download-Dokument«. Dort hängt Ihr das Bild an. Eine Bitte: Schreibt in den Titel »Nicht veröffentlichen« und einen kurzen Kommentar, was das Posting soll, in den Textkörper. Sonst macht Ihr Leuten wie Roland Buchloh oder mir viel Zusatzarbeit.

Sobald Ihr ein Bild angehängt habt, liegt das auf dem Server, auch, wenn der Beitrag selbst nicht frei geschaltet ist. Ihr seht in dem Formular auch den kompletten URL, in meinem Beispiel »http://experts.ragtime.de/experts/files/bildbeispiel.png«

In einem Forum-Posting könnt Ihr den verwenden in einem Bild-Link in der Form

<img src="http://experts.ragtime.de/experts/files/bildbeispiel.png" />

Und so sieht das dann aus:

Bitte benutzt den vollständigen URL, sonst sehen Teilnehmer der Mailingliste das Bild nicht. (Dank an Thomas Kaegi für diesen Hinweis.)

Ihr könnt Euch auch einen Bookmark auf das Bearbeiten-Formular für die Seite mit dem Bild als Bookmark merken, aber bitte mit dem »edit« am Ende. Bei mir war das zum Beispiel »http://experts.ragtime.de/experts/node/3264/edit«. Mit diesem Bookmark kommt Ihr wieder an Eure eigene Seite heran und könnt sie später wieder benutzten.

Gruß, Jürgen

Re: Bildanhänge im Forum

#10045 On 1 März, 2011 09:25 Thomas Kaegi said,

(Beitrag redigiert am 12.12.13)

Das ist sicher ein Weg für all jene, die keinen Zugriff auf einen eigenen Serverplatz oder eine Cloud haben. Viele User haben aber heute Speicherplatz bei ihrem Provider oder ein Account in irgend einer Cloud, und können ihr Bild dort ablegen und den Zugriff darauf erlauben. (Das Bild von unserem "Toblerone-Berg" ist von mir - also keine ©-Verletzung.)

Zu den Clouds allerdings diese einschränkende Bemerkung: In Clouds wie Dropbox lassen sich zwar Bilder veröffentlichen. Aber sie können mit dem Link nicht in Dokumente eingebunden werden. Bei Bildern schaltet Dropbox mit dem Link sofort in den Bildbetrachtungsmodus. Also kann zwar in einem Forumbeitrag der betreffende Link angegeben werden, aber das Bild wird nicht direkt im Forumbeitrag angezeigt. Ein solcher Link kann dann so aussehen:

https://www.dropbox.com/s/07f6u3ez7l93bt4/Matterhorn_fuer_RT_Forum.jpg

Liegt das Bild auf einem Server, so erfolgt die Einbindung mit dem Code
«IMG SRC="http://www.mein_server.ch/Matterhorn_fuer_RT_Forum.jpg"»
zwischen einfachen statt doppelten spitzen Klammern.

Damit stehen für die Bildveröffentlichungen im Forum mehrere Wege zur Verfügung.

Gruss, Thomas

Re: Bildanhänge im Forum

#12320 On 4 Januar, 2017 11:03 Thomas Kaegi said,

Eine Bemerkungen zu meinem obigen Beitrag:
Ich habe das Bild seither in meiner Dropbox gelöscht, so dass die Aussage zwar noch stimmt, dass der Link so aussehen kann, aber ein Klick auf den Link führt zu einer Fehlermeldung 404, dass das gesuchte Element nicht gefunden werde.

Eine Bemerkung zum Beitrag von Jürgen:
Ich konnte seine Vorgehensweise nicht mehr nachvollziehen – seinerzeit scheint es geklappt zu haben. Die Aussage, dass der vollständige URL des Bildes im Formular angezeigt würde, selbst wenn der Beitrag noch gar nicht abgeschickt worden sei, scheint nicht zu stimmen. Selbst wenn auf "Vorschau" geklickt wird, ist lediglich ein temporärer Speicherort ersichtlich.

Somit bleiben nur die von mir vorgeschlagenen Möglichkeiten, vorzugsweise diejenige mit dem eigenen Server.

Thomas

Re: Bildanhänge im Forum

#12321 On 4 Januar, 2017 13:22 Jochen said,

@Thomas

Mir ist unklar wieso Du das schreibst.
Ich haben in meinem Beitrag http://experts.ragtime.de/experts/node/3851 habe ich es so gemacht wie Jürgen Schell es am 28. Februar, 2011 - 16:19 beschrieben hat.

Die Anhänge sind bei mir heute 04.01.2017 13:20 zu sehen.

Jochen

Re: Bildanhänge im Forum

#12322 On 4 Januar, 2017 14:14 Thomas Kaegi said,

@ Jochen

Mir ist ebenso unklar, wie es bei dir funktionieren kann. Auf meinem Mac mit Safari kommt ein kleines blaues Quadrat mit Fragezeichen, auf dem iPhone ein kleines Quadrat mit hellgrauem Rand. Wenn ich den Link des blauen Quadrates kopiere, dann erhalte ich:

http://experts.ragtime.de/experts/files/C1%20Farbprofil_0.png

Wenn ich diesen Link als URL in Safari direkt eingebe erhalte ich die Meldung "Seite nicht gefunden" – kein Wunder also, dass in deinem Beitrag auch kein Bild angezeigt wird.

Mir ist aber schon mal unklar, wie du den Link zum Bild gefunden hast, denn entgegnen der Beschreibung von Jürgen wird er – wenigstens bei mir – nicht im Eingabeformular für den "Beitrag mit Download" angezeigt. Eben habe ich es nochmals mit einem Testbild versucht. Hochgeladen wurde es, aber nirgends ist der URL gezeigt.

Thomas

Re: Bildanhänge im Forum

#12323 On 4 Januar, 2017 14:53 Jochen said,

@Thomas

Auf meinen iPad mit iOS 8.1.2 erscheint unter Safari auch ein kleines graue Quadrat.

Mit OS X.10.11.6 und Safari habe ich es so gemacht wie hier beschrieben.

Man muss folgende Seite aufrufen.

http://experts.ragtime.de/experts/node/add/flexinode-4

Nach Einträgen unter Titel, Kurzbeschreibung, Ausführliche Beschreibung unter Anhänge ganz unten Datei auswählen durchgeführt.
Entsprechende Datei vom Schreibtisch ausgewählt.
Vorschau ausgewählt.
Dann sieht man bei Anhäge die URL.
Diese URL kopiert und mit Pfeil nach links img scr = "URL" Schrägstrich Pfeil nach rechts eingefügt.

Habe die „Formel" jetzt textlich beschrieben.

Jochen

Re: Bildanhänge im Forum

#12680 On 25 Dezember, 2018 11:06 Thomas Kaegi said,

Das Einfügen von Bildern in gewöhnliche Forumbeiträge geht ziemlich einfach, allerdings nur, wenn der wichtige Hinweis zur Namensgebung der Bilder beachtet wird! Hier nochmals Schritt für Schritt:

  1. Links im Forum auf "Beitrag schreiben" klicken
  2. Option "Beitrag mit Download-Dokument" wählen
  3. Als Titel und als Kurzbeschreibung je diesen Text eingeben: "Bild zu Forumbeitrag JJJJMMTT (nicht veröffentlichen!)", wobei "JJJJMMTT" durch das aktuelle Datum zu ersetzen ist.
  4. Dem hochzuladenden Bild einen eindeutigen Namen geben. Alle je zu RagTime hochgeladenen Bilder werden in den gleichen Ordner abgelegt. Um die Eindeutigkeit des Bildnamens sicherzustellen, darf sicher z.B. nicht einfach "Bildschirmfoto" gewählt werden. Am sichersten ist Eindeutigkeit durch Einbezug des Datums herzustellen. Also z.B. "Bildschirmfoto_JJJJMMTT" (wobei ein Unterstrich dem Leerzeichen als Trenner vor dem Datum vorzuziehen ist).
  5. Ganz zuunterst unter "Neue Datei anhängen" auf "Datei auswählen" klicken und das Bild auswählen
  6. Auf "Anhängen" klicken
  7. Jetzt wird der URL des hochgeladenen Bildes direkt oberhalb angezeigt - auswählen und kopieren
  8. Im Text des Forumbeitrags kann nun dieser Link in der Form eingebaut werden, wie ihn Jürgen Schell in seinem ursprünglichen Beitrag (zuoberst in dieser Diskussion) angegeben hat, also:

<img src="Link aus dem Zwischenspeicher hier einsetzen">
in obigem Beispiel also:
<img src="http://experts.ragtime.de/experts/files/Bildschirmfoto_JJJJMMTT">

Für mehrere Bilder sind die Schritte 4-8 zu wiederholen, wobei den Bildern natürlich unterschiedliche Namen zu geben sind.
NB: Der Beitrag, mit dem ein oder mehrere Bilder hochgeladen wurden, muss gar nicht gespeichert werden. Diese bleiben trotzdem auf dem Server bei RagTime erhalten.

Thomas